TERA Online forum archive
Player Guides: tera's animation not properly showing on my laptop. pls help
View post on Tera forums#1 7GF35AEKXT01/10/2018, 04:26 AM
i downloaded tera a few days ago with my sister and we are loving it. such a good game however i have been experiencing a few problem. when you first get into the game after selecting your server u see this blue portal thing, i dont see it but on my sisters screen it shows up on mine its just a plain blue screen. also the vilagers and other players take a really long time to load as in texture, i see grey silhouettes. i experience this when im flyinfg too, when i was on the pegasus to go to the next city all i see is a black screen and i assume that its meant to be the sky but i dont see it. pls tell me a solution for this, thanks
View post on Tera forums#2 Salsychou01/13/2018, 09:22 PM
tl;dr in bold
If you're missing textures that aren't loading at all, maybe you should repair the game through the client.
If it's just the textures taking a long time, it has to do with your computer. It's a CPU-heavy rather than a GPU-heavy game so it doesn't run the best unless you have the best. AMDs don't run this game very well at all imo, so that's already a disadvantage. If you want things to load quicker, you're gonna have to scale the settings down. If you want to enjoy the game's graphics, you can probably play at 5-6 when you're in the field, and then scale down to 0 when you're in dungeons. There are some dungeons that still run at 6, but you should probably stick to 0 once you get to the upper dungeons so that you don't run into the boss taking a long time to load.
You can contact Tera Online dev tracker at contact@teradevtracker.com - Privacy policy - Tera Online dev tracker is not affiliated with Tera Online or En Masse entertainment.